Mod Users: Knowing if a mod is compatible with your Towns.

Post here your released mods

Mod Users: Knowing if a mod is compatible with your Towns.

Postby tom k. » Tue May 14, 2013 1:06 pm

This is just a quick note on how versions work, and the implications of mod compatibility.

A brief guide to versions.

Before November 7th 2012 (IE: The release on steam), the game used an arbitrary numbering system in the form or "0.XX.Y" where XX was a number, represnting the build (sort of) and where Y was occasioally a letter representing a fix. These mods usually involved manual code edits, or the use of a third party modloader to autoinstall the code.

After the steam release, the versioning system was changed to be in the form of "vXY" such as "v8a", or "v12b". This was a stipulation of the release on steam - because steam doesn't like verison numbers beginning with a 0...

Skip forward to v12. The devs implemented a built in modloader to the game.


Version Compatibility.

  • Mods marked as "0.46 MM_1.1" are designed for version 0.46 of the game (wayyyyyy back), and require ModManager (a third party modloader for old versions of towns).
  • Mods marked as "DIY 0.46" are compatible, again, with version 0.46 of Towns, but only require manual code edits. Because these mods are manually installed by copying and pasting, someone with a decent knowledge of the game's XML can modify them to be compatible with later versions - but I would not reccommend ti to beginners.
  • Mods marked as "v8" or "v7" can also use the ModManager, or are DIY. These mods are NOT compatible with the integrated modloader from v12.
  • Mods marked as "v12" of higher use the integrated modloader. There are still some mods for v12, v13 and possibly any other versions, that are simply TOO complex for the modloader, and must be installed manually.

Finally, it is entirely possible that mods designed for the v12 modloader will work in newer versions of the game, but compatibility is not guaranteed.
Tom K.
Former Community Moderator


Please read the FAQs before posting.
Image
Towns' Official Modding Partner Site - Townsmods.net
tom k.
 
Posts: 1605
Joined: Wed Mar 28, 2012 7:22 pm
Location: Lincoln, UK

Re: Mod Users: Knowing if a mod is compatible with your Town

Postby YetiChow » Thu May 23, 2013 12:14 pm

Just to add my $0.02: if in doubt, ask the original modder via PM or, if they don't respond, someone from the modding forum. It's a lot easier to answer a direct question than it is to explain why your game crashes with the mod in ;)

We're a friendly bunch, so don't hesitiate to ask around if you're unsure. If it isn't compatible then that might even prompt someone to update the mod (or make a new one with the same result) for you :)
What's that you're eating? A nice, juicy apple? You weren't supposed to eat that you fool, you were supposed to make it into a pie! - last words recorded words of Francis D'Avre before he went looking for snowcherries, but found a hungry Yeti instead.
User avatar
YetiChow
 
Posts: 3149
Joined: Wed Apr 25, 2012 9:26 am
Location: Cramped between a Yeti's small intestine and its stomach... trying not to dissolve!


Return to Released mods

Who is online

Users browsing this forum: No registered users and 2 guests

cron